Connector- No option to take me to next step after recording a query


#1

Hi guys,
I have been been trying to create a connector on the desktop app. I can get to recording a query and making an input but then there is no option for me to continue with creating the connector. The “take me to the next step…” button is not appearing.
Can anyone help me with this?


#2

Does it allow you to stop the recording?

If not, record yourself refreshing the page as the first action, before your search input.

If this doesn’t work, feel free to post the URL and the search terms you are trying to use.

Alex


#3

Hi, yes it does allow me to stop recording. I’m really quite frustrated !!! This is the URL https://fdc.taleo.net/careersection/fdc_external/jobsearch.ftl?lang=en

Any help would be really appreciated :slight_smile:

Amy


#4

@JenkinsJacob

With some fiddling with the javascript on/off setting I was able to get past this stage.

However, the Connector doesn’t handle the pagination. The website uses javascript to populate the items on the next pages and it breaks the connector when you try to change page.

Websites that handle pagination in this way are much more difficult to extract from. They are not as common, but unfortunately, this site is one of them.

The only way I can think of getting data from this site is to use multiple search terms that keep results to 1 page maximum. Not ideal - I know.

Sorry I couldn’t be more help.

Alex


#5

Thanks - not quite what I wanted but the workaround could be a way forward :slight_smile:

BTW when you say, turning the javascript on and off, do you mean selecting the option “my results are visible” or is there a toggle button somewhere like there is when you build an extractor?

PS! lol I noticed there is a web extractor now, can we replicate the connector functionality using the web tool or do I still need to keep using the desktop tool?

Amy


#6

Hey Amy,

Yes I meant the “my results are visible/its not working” buttons - (don’t ask my why they’re names this - long before my time ;)) There isn’t a toggle like the Extractor.

The Web Extractor is still a baby, so can’t handle connector functionality yet I’m afraid.

If there is another website that contains this data, we can also try that!

Alex


#7

Hi, Alex,
I have the same problem as JenkinsJacob but with this page: http://www.eiaab.com/entries/detail/CD166_HUMAN.
Trying to record connector to switch between dropdown menu items: http://image.prntscr.com/image/8ae5850326b74997aa17bf05b9e8ddfe.jpeg
But when I click “stop”, the only option I see is to start recording again. I tried to refresh the page before recording, before clicking the stop button and after this, but this didn’t work for me.


#8

Hello,

I am experiencing this exact same problem, but on this page: www.yelp.com/search. I have a list of addresses and am trying to generate a list of nearby restaurants. I can record the query, but there is no option to proceed to the next step. I would very much appreciate assistance.

Thank you,

TS


#9

I am not able to scrap “View Contact Details” from the below page as it needs human click. I tried connector but it doesn’t able to record. http://www.naukri.com/job-listings-Software-Developer-Collabera-Technologies-Pvt-Ltd--Chennai-3-to-6-years-090616000555?src=jobsearchMob&sid=14673537253042&xp=4


#10

Hi @zaskock,

Did you figure this one out?

You don’t need a connector. You can use the Web Extractor ( http://mport.io ) and either turn CSS off in the column settings, or use XPaths.

The data is in still in the html even if it is hidden from view.

:slight_smile:
Alex


#11

I’m afraid you won’t have a lot of luck with Yelp at the moment.

They have quite a lot of anti scraping measures. We’re working on increasing our IP pool and rotation to combat this kind of thing going forwards.

:slight_smile:
Alex


#12

When recording with a connector, try to record refreshing the page as your first action.

Alex


#13

Is there a bug? I experienced the same issue whenever I enable Javascript. There’s no option for me to proceed to the next page.
Without javascript enabled, I am unable to extract any data.
The website I was working on was